Symptômes
Supposons que vous utilisez Microsoft SQL Server 2012 ou SQL Server 2014. En cas d’exécution répétée d’une procédure stockée qui extrait des données d’une table temporaire au cours d’une même session, le message d’erreur suivant s’affiche :
Remarque
Error : 602, Severity : 21, State : 30.Impossible de trouver une entrée pour la table ou l’index avec l’ID < de partition ID de partition> dans le nom de la base de données de> la base de données<. Cette erreur peut se produire si une procédure stockée fait référence à une table abandonnée ou si les métadonnées sont endommagées. Supprimez et recréez la procédure stockée, ou exécutez DBCC CHECKDB.
Remarque Ce problème est plus susceptible de se produire sur un système qui comporte de nombreux processeurs, par exemple, un ordinateur qui en possède 20.
Résolution
Ce problème a été résolu dans la mise à jour cumulative de SQL Server suivante :
- Mise à jour cumulative 3 pour SQL Server 2014 SP1
- Mise à jour cumulative 10 pour SQL Server 2014
- Mise à jour cumulative 8 pour SQL Server 2012 SP2
Recommandation : Installer la dernière mise à jour cumulative pour SQL Server
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Nous vous recommandons de télécharger et d’installer les dernières mises à jour cumulatives pour SQL Server :
- Dernière mise à jour cumulative pour SQL Server 2014 SP1
- Dernière mise à jour cumulative pour SQL Server 2014
- Dernière mise à jour cumulative pour SQL Server 2012 SP2
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».