KB2836537 - CORRECTIF : Performances de restauration des métadonnées ralenties et fichiers de sauvegarde orphelins incomplets sur le stockage Blob Microsoft Azure lors de l’échec de la sauvegarde dans SQL 2012

S’applique à
SQL Server 2012 Enterprise SQL Server 2012 Business Intelligence SQL Server 2012 Developer SQL Server 2012 Standard SQL Server 2012 Web SQL Server 2012 Express SQL Server 2012 Enterprise Core

Les correctifs de Microsoft SQL Server 2012 Service Pack 1 sont distribués sous la forme d’un fichier téléchargeable. Étant donné que les correctifs sont cumulatifs, chaque nouvelle version contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente du correctif SQL Server 2012 Service Pack 1.

Symptômes

Problème 1

Supposons que vous exécutez l’une des instructions suivantes pour restaurer une base de données à partir du service Stockage Blob Microsoft Azure :

  • RESTAURER HEADERONLY
  • RESTAURER LA LISTE DE FICHIERSUNIQUEMENT
  • RESTORE LABELONLY

Dans cette situation, l’exécution des opérations peut être beaucoup plus lente que prévu.

Problème 2

Supposons que lorsque vous sauvegardez une base de données sur Stockage Blob Microsoft Azure, certaines erreurs se produisent et l’opération de sauvegarde est fermée de manière inattendue.

Dans ce cas, les fichiers de sauvegarde incomplets peuvent être écrits dans le stockage Blob Microsoft Azure. En outre, si vous utilisez les fichiers incomplets pour restaurer la base de données, le message d’erreur suivant s’affiche :

Remarque

Msg 3203, Niveau 16, État 1, Ligne 1
Échec de la lecture sur « URL » : la sauvegarde vers l’URL a reçu une exception du point de terminaison distant. Message d’exception : Le serveur distant a renvoyé une erreur : (409) Conflit.

Msg 3013, Niveau 16, État 1, Ligne 1
RESTORE FILELIST se termine anormalement.

          

Résolution

Après avoir appliqué cette mise à jour, SQL Server essaie de supprimer le fichier de sauvegarde incomplet sur lequel l’opération de sauvegarde écrivait. Si l’opération de sauvegarde ne peut pas récupérer l’accès au fichier de sauvegarde incomplet, par exemple lorsque l’opération est en déconnexion à long terme ou perpétuelle, le fichier peut rester orphelin. Dans ce cas, vous devez supprimer manuellement le bail sur le fichier de sauvegarde et supprimer le fichier de sauvegarde. Pour plus d’informations, consultez Suppression de Files d’objets blob de sauvegarde avec des baux actifs

Informations sur les mises à jour cumulatives

Mise à jour cumulative 4 pour SQL Server 2012 SP1

Le correctif pour résoudre ce problème a été publié pour la première fois dans la mise à jour cumulative 4. Pour plus d’informations sur la procédure d’obtention de ce package de mise à jour cumulative pour SQL Server 2012 SP1, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

2833645 Mise à jour cumulative 4 pour SQL Server 2012 SP1Note Étant donné que les builds sont cumulatives, chaque nouvelle version de correctif contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente du correctif SQL Server 2012 SP1. Nous vous recommandons d’envisager d’appliquer la version la plus récente du correctif qui contient ce correctif. Pour plus d’informations, cliquez sur le numéro ci-dessous pour accéder à l’article correspondant dans la Base de connaissances Microsoft :

2772858 Builds de SQL Server 2012 publiées après SQL Server 2012 Service Pack 1

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Références

Pour plus d’informations sur la sauvegarde et la restauration de SQL Server sur le stockage Blob Microsoft Azure, consultez le blog MSDN suivant :

SQL Server Sauvegarde et restauration dans le cloud simplifiées Pour plus d’informations sur le modèle de maintenance incrémentielle pour SQL Server, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

935897 Un modèle de service incrémentiel est disponible auprès de l’équipe SQL Server pour proposer des correctifs logiciels pour les problèmes signalés Pour plus d’informations sur le schéma d’appellation des mises à jour SQL Server, cliquez sur le numéro ci-dessous pour accéder à l’article correspondant dans la Base de connaissances Microsoft :

822499 Schéma d’appellation des packages de mise à jour logicielle Microsoft SQL Server Pour plus d’informations sur la terminologie de mise à jour logicielle, cliquez sur le numéro ci-dessous pour accéder à l’article correspondant dans la Base de connaissances Microsoft :

824684 Terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft