KB2894326 - Une application ne peut pas se connecter à une base de données contenue lorsque le regroupement de connexions est activé dans SQL Server 2012 ou SQL Server 2014

S’applique à
SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Express SQL Server 2012 Parallel Data Warehouse SQL Server 2012 Standard SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Symptômes

Prenons le scénario suivant :

  • Vous disposez d’une base de données contenue dans Microsoft SQL Server 2012 ou SQL Server 2014.
  • Une application tente de se connecter à la base de données contenue en activant le regroupement de connexions.
  • L’application utilise l’authentification SQL Server.

Dans ce scénario, l’application peut ne pas réussir à se connecter à la base de données. En outre, des erreurs semblables aux suivantes apparaissent dans le journal des erreurs de SQL Server :

Remarque

Date et heure Erreur d’ouverture de session : 18456, Gravité : 14, État : 5.
datetime Échec de la connexion pour l’utilisateur « SID ». Raison : Impossible de trouver un nom d’accès correspondant au nom fourni [Client :]
datetime spid# Error : 18056, Severity : 20, State : 5.
datetime spid# Le client n’a pas pu réutiliser une session avec SPID #, qui avait été réinitialisé pour le regroupement de connexions. L’ID d’échec est #. Cette erreur peut être due à l’échec d’une opération antérieure. Vérifiez les journaux d’erreurs pour les opérations ayant échoué juste avant ce message d’erreur.

Remarque Ce problème ne se produit pas la première fois qu’une connexion à une base de données contenue se produit. Toutefois, le problème se produit à toutes les tentatives successives.

Résolution

Le problème a été résolu pour la première fois dans la mise à jour cumulative suivante de SQL Server.

Mise à jour cumulative 1 pour SQL Server 2014 /en-us/help/2931693

Mise à jour cumulative 7 pour SQL Server 2012 SP1 /en-us/help/2894115

À propos des mises à jour cumulatives pour SQL Server

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

      

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Informations supplémentaires

Cette mise à jour corrige également un autre problème selon lequel les fonctions intégrées suivantes renvoient le SID de l’utilisateur au lieu du nom d’utilisateur :

  • SUSER_SNAME
  • SUSER_NAME
  • SYSTEM_USER

Remarque : cette mise à jour garantit que le nom d’utilisateur est toujours renvoyé par ces fonctions, qu’une base de données contenue soit utilisée ou non.

Références

Consultez la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.