KB2994082 - CORRECTIF : Erreur lors de la modification des modèles de certains groupes ou utilisateurs dans MDS pour SQL Server 2012 ou SQL Server 2014

S’applique à
SQL Server 2012 Enterprise SQL Server 2012 Developer SQL Server 2012 Standard SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Symptômes

Supposons que vous avez supprimé une ou plusieurs entités dans Master Data Services (MDS) pour Microsoft SQL Server 2012 ou SQL Server 2014. Lorsque vous essayez de modifier la sécurité du modèle pour certains groupes ou utilisateurs dans MDS, le message d’erreur suivant s’affiche :

Remarque

Une erreur inconnue s’est produite.

Remarque Quand vous activez la journalisation du suivi MDS et reproduisez l’erreur, le message d’erreur suivant est détecté dans le journal de suivi :

Remarque

Un élément avec la même clé a déjà été ajouté.

Cause

Le problème se produit parce que la sécurité de niveau d’attribut qui appartient à l’entité supprimée n’est pas supprimée en conséquence.

Résolution

Le problème a été résolu pour la première fois dans la mise à jour cumulative suivante de SQL Server.

Mise à jour cumulative 1 pour SQL Server 2014 SP1 /en-us/help/3067839

Mise à jour cumulative 6 pour SQL Server 2014 /en-us/help/3031047

Mise à jour cumulative 4 pour SQL Server 2012 SP2 /en-us/help/3007556

Mise à jour cumulative 13 pour SQL Server 2012 SP1 /en-us/help/3002044

À propos des mises à jour cumulatives pour SQL Server

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

      

Solution de contournement

Pour contourner ce problème, supprimez le niveau de sécurité de l’attribut correspondant ou supprimez les attributs référencés dans la sécurité du groupe. Ensuite, supprimez l’entité.

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».