Symptômes
Dans Microsoft SQL Server 2012 ou SQL Server 2014, vous essayez de sauvegarder une base de données volumineuse à l’aide de l’applet de commande Backup-SqlDatabase, ou de restaurer une base de données volumineuse à l’aide de l’applet de commande Restore-SqlDatabase. Dans ce cas, une erreur de délai d’attente se produit après 10 minutes. En outre, le message d’erreur suivant s’affiche dans Windows PowerShell :
Remarque
Expiration du délai d’attente. Le délai d'expiration s'est produit avant la fin de l'opération ou le serveur ne répond pas.
Cause
Le problème se produit car les applets de commande Backup-SqlDatabase et Restore-SqlDatabase utilisent 600 secondes comme valeur de délai d’attente par défaut.
Résolution
Le problème a été résolu pour la première fois dans la mise à jour cumulative suivante de SQL Server.
Mise à jour cumulative 1 pour SQL Server 2014 /en-us/help/2931693
Mise à jour cumulative 8 pour SQL Server 2012 SP1 /en-us/help/2917531
À propos des mises à jour cumulatives pour SQL Server
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :
- Dernière mise à jour cumulative pour SQL Server 2014
- Dernière mise à jour cumulative pour SQL Server 2012 SP1
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».