INTRODUCTION
Cet article décrit le package de mise à jour cumulative 4 pour Microsoft SQL Server 2012. Cette mise à jour contient des correctifs logiciels pour des problèmes résolus après la publication de SQL Server 2012.
Remarque Le numéro de build de ce package de mise à jour cumulative est 11.0.2383.0.
Nous vous recommandons de tester les correctifs logiciels avant de les déployer dans un environnement de production. Étant donné que les builds sont cumulatives, chaque nouvelle publication de correctif contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente du correctif SQL Server 2012. Nous vous recommandons d’envisager d’appliquer la version la plus récente du correctif qui contient ce correctif.
Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
2692828 Les builds SQL Server 2012 publiées après la sortie de SQL Server 2012
Remarques importantes sur le package de mise à jour cumulative
- Les correctifs logiciels de SQL Server 2012 sont désormais multilingues. Il n’existe donc qu’un seul correctif logiciel cumulatif pour toutes les langues.
- Un correctif logiciel cumulatif inclut tous les packages des composants. Le package de mise à jour cumulative met à jour uniquement les composants installés sur le système.
Informations supplémentaires
Procédure pour obtenir la mise à jour cumulative 4 pour SQL Server 2012
Un package de mise à jour cumulative pris en charge est désormais disponible auprès de Microsoft. Toutefois, elle est destinée à corriger uniquement les problèmes décrits dans cet article. Appliquez-le uniquement aux systèmes qui rencontrent ces problèmes spécifiques. Ce package de mise à jour cumulative peut subir des tests supplémentaires. Par conséquent, si vous n’êtes pas sérieusement concerné par ces problèmes, il est recommandé d’attendre la prochaine version du Service Pack SQL Server 2012 qui contiendra les correctifs logiciels contenus dans ce package de mise à jour cumulative.
Si la mise à jour cumulative est disponible en téléchargement, une section « Téléchargement de correctif logiciel disponible » figure en haut du présent article de la Base de connaissances. Si cette section est absente, procurez-vous le package de mise à jour cumulative auprès des services de Support technique Microsoft.
Remarque Si des problèmes supplémentaires surviennent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s’appliqueront aux autres questions et problèmes non directement liés à ce package de mise à jour cumulative. Pour obtenir la liste complète des numéros de téléphone des services d’assistance technique Microsoft ou pour créer une demande de service distincte, reportez-vous au site web de Microsoft à l’adresse suivante :
Correctifs logiciels inclus dans ce package de mise à jour cumulative
Les articles de la Base de connaissances Microsoft qui traitent de ces correctifs logiciels seront publiés dès qu’ils seront disponibles.
Pour plus d’informations sur les bogues de SQL Server dans la liste suivante, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft.
| Numéro de bogue VSTS | Numéro d’article de la Base de connaissances | Description |
|---|---|---|
| 1056314 | 2406666 | CORRECTION : erreur « [Base de données Teradata] [3737] » lorsque vous cliquez sur « Nombre » dans l’Assistant Conception d’agrégation dans SSAS 2008, SSAS 2012 ou SSAS 2008 R2 |
| 969184 | 2661644 | CORRECTIF : Violation d’accès dans le sqlservr ! Fonction ReplicaToPrimaryPageCopier ::ReadIoCompletionRoutine dans SQL Server 2008 R2 ou dans SQL Server 2008 R2 |
| 872764 | 2671318 | CORRECTIF : la première exécution de la procédure stockée xp_cmdshell ne se termine pas avant la fin de la dernière exécution en SQL Server 2012 |
| 1043442 | 2714634 | CORRECTIF : SQL Server 2008 R2 ou SQL Server 2012 prend beaucoup de temps pour générer des scripts pour une table partitionnée qui utilise la fonctionnalité de compression de données |
| 1043432 | 2723979 | CORRECTIF : violation d’accès dans le moniteur de blocage interne de SQL SQL Server lorsque vous exécutez plusieurs applications avec plusieurs jeux de résultats actifs activés dans SQL Server 2008 R2 ou dans SQL Server 2012 |
| 1043428 | 2728419 | CORRECTIF : message d’erreur « Le processus de réglage s’est arrêté de manière inattendue » lorsque vous exécutez Assistant Paramétrage du moteur de base de données sous le rôle db_owner dans SQL Server 2008 R2 ou dans SQL Server 2012 |
| 1043434 | 2728534 | CORRECTIF : erreur « une assertion système case activée a échoué » lorsque vous recréez un index non-cluster sur une colonne dans SQL Server 2008 R2 ou dans SQL Server 2012 |
| 1043440 | 2731068 | CORRECTIF : « Une erreur inattendue s’est produite » lorsque vous interrogez des données de calcul d’un modèle tabulaire SSAS à l’aide de SQL Server 2008 R2 PowerPivot pour Excel 2010 ou de SQL Server 2008 R2 PowerPivot pour SharePoint 2010 |
| 1043448 | 2733630 | L’agent de fusion peut échouer pendant la synchronisation de la réplication de fusion dans SQL Server 2008 R2 ou dans SQL Server 2012 |
| 1043455 | 2733673 | CORRECTIF : message d’erreur « Les mises à jour ad hoc des catalogues système ne sont pas autorisées » lorsque vous utilisez SSMS pour SQL Server 2008 R2 ou SQL Server 2012 pour modifier les propriétés du serveur lié |
| 1043436 | 2737499 | CORRECTIF : La propriété KeepTogether ne fonctionne pas lorsque vous générez un rapport contenant un tableau matriciel dans SSRS 2008 R2 ou SSRS 2012 |
| 1028254 | 2737580 | CORRECTIF : erreur interne lors de l’exécution de requêtes sur un modèle d’extraction non rectangulaire à l’aide de DMX ou MDX dans SQL Server 2012 Analysis Services |
| 1009860 | 2738197 | CORRECTIF : les threads de travail ne se réveillent pas immédiatement lorsque plusieurs tâches gourmandes en E/S s’exécutent en même temps dans SQL Server 2012 |
| 1019868 | 2739940 | CORRECTIF : la base de données est hors connexion et en état de récupération lorsque vous reconstruisez un index dans SQL Server 2012 si le journal des transactions est saturé |
| 1043454 | 2740507 | CORRECTIF : Message d’erreur « Impossible d’obtenir les types de données pris en charge à partir de la connexion à la base de données » lors de l’utilisation de l’Assistant Importation et exportation de données pour vous connecter à une base de données Sybase dans SQL Server 2008 R2 ou dans SQL Server 2012 |
| 1044000 | 2752511 | CORRECTIF : Message « Erreur de dépassement de capacité arithmétique » lors de l’exécution de la procédure stockée système sys.sp_tables_info_90_rowset_64 sur un serveur lié dans SQL Server 2012 |
| 1046164 | 2754444 | CORRECTION : Message d’erreur « L’index et la longueur doivent faire référence à un emplacement dans la chaîne » lorsque vous extrayez un grand volume de données de SAP BW dans un package SSIS 2012 |
| 1048061 | 2754939 | CORRECTIF : Une violation d’accès se produit lorsque vous exécutez une requête en texte intégral dans SQL Server 2012 |
| 1056330 | 2755079 | CORRECTIF : les modifications ne sont pas synchronisées pour les abonnés après la modification d’un filtre d’article dans une publication transactionnelle dans SQL Server 2008, SQL Server 2012 ou SQL Server 2008 R2 |
| 985109 | 2756097 | CORRECTIF : « Aperçu de la technologie de la communauté (CTP d’août) » s’affiche dans l’Assistant Installation ou désinstallation d’une mise à jour de SQL Server 2012 |
| 1043772 | 2758569 | CORRECTIF : Message d’erreur « Échec de l’opération avec l’erreur 0x8007000B » lors de l’exécution d’une installation non attachée pour ajouter SQL Server 2012 bits Reporting Services |
| 1043740 | 2758628 | Mise à jour corrigeant un problème d’exactitude de la fonction SUMMARIZE et améliorant la fonctionnalité de mise en cache dans SQL Server 2012 |
| 985483 | 2762557 | CORRECTIF : message d’erreur « La liste> rouge du processus <semble ne pas céder sur l’ID> du planificateur <» lorsque vous exécutez une requête dans SQL Server 2012 |
| 1051891 | 2762559 | CORRECTIF : les échecs de SQL Server 2012 sont affichés dans la boîte de dialogue Notifications d’état de tâche dans System Center Operations Manager 2012 |
| 1056385 | 2762593 | CORRECTIF : L’utilitaire tablediff signale des résultats incorrects lorsqu’un tableau contient une clé primaire sur une colonne identificateur unique dans SQL Server 2012 |
Informations sur le package de mise à jour cumulative
Informations sur le redémarrage
Vous devrez peut-être redémarrer l’ordinateur après avoir appliqué cette mise à jour cumulative.
Informations sur le Registre
Pour utiliser l’un des correctifs logiciels contenus dans ce package, il n’est pas nécessaire de modifier le Registre.
Comment désinstaller ce package de mise à jour cumulative
Pour désinstaller ce package de mise à jour cumulative, procédez comme suit :
Dans le Panneau de configuration, ouvrez Ajout/Suppression de programmes
l’objet.Remarque Si vous utilisez Windows 7, ouvrez l’élément Programmes et fonctionnalités du Panneau de configuration.
Recherchez l’entrée installée par ce package de mise à jour cumulative.
Cliquez avec le bouton droit sur l’entrée, puis cliquez sur Désinstaller.
Références
Pour plus d’informations sur le modèle de maintenance incrémentielle pour SQL Server, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft.
935897
Un modèle de service incrémentiel est disponible auprès de l’équipe SQL Server pour proposer des correctifs logiciels pour les problèmes signalés
Pour plus d’informations sur le schéma d’appellation pour les mises à jour de SQL Server, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
822499
Schéma d’appellation des packages de mise à jour logicielle de Microsoft SQL Server
Pour plus d’informations sur la terminologie de mise à jour logicielle, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
824684
Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft