Symptomen
Stel dat u een SQL Server 2017 Linux-containerinstallatiekopie uitvoert op Docker voor Windows. Wanneer Docker-installatiekopieën worden gebruikt voor het inrichten van containers en u een volumekoppelingslocatie (standaardlocatie van /var/opt/mssql) of een bovenliggende map gebruikt, wordt SQL Server niet gestart. Bovendien wordt een foutbericht van de volgende strekking weergegeven:
Opmerking
datum tijd spid6s Fout: 17053, ernst: 16, status: 1.
datum tijd spid6s /var/opt/mssql/data/mastlog.ldf: Besturingssysteemfout 31 (een apparaat dat is aangesloten op het systeem functioneert niet.) is opgetreden.
datum tijd spid6s Fout: 9002, ernst: 17, status: 0.
datum tijd spid6s Het transactielogboek voor database 'master' is vol vanwege 'NIETS'.
datum tijd spid6s Fout: 928, ernst: 20, status: 1.
Oorzaak
Dit probleem treedt op omdat de map van Windows is gekoppeld als CIFS (Common Internet File System) in de Docker-container. CIFS wordt officieel niet ondersteund als bestandssysteem door SQL Server on Linux.
Oplossing
De oplossing voor dit probleem is opgenomen in de volgende update voor SQL Server:
Cumulatieve update 7 voor SQL Server 2017
Over builds van SQL Server
Elke nieuwe build voor SQL Server bevat alle hotfixes en beveiligingspatches uit de vorige build. We raden u aan de nieuwste build voor uw versie van SQL Server te installeren:
De nieuwste build voor SQL Server 2017
Status
Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in de sectie Van toepassing op.
Meer informatie
Meer informatie over de standaardterminologie die Microsoft gebruikt om software-updates te beschrijven.
Disclaimerinformatie van derden
De producten van derden die in artikel worden beschreven, worden geproduceerd door bedrijven die onafhankelijk van Microsoft zijn. Microsoft biedt geen garantie, uitdrukkelijk noch impliciet, voor de prestaties en betrouwbaarheid van deze producten.