Symptomen
Stel dat u de functie AlwaysOn-beschikbaarheidsgroepen in SQL Server 2017 gebruikt. Er kan een toegangsfout optreden en het verplaatsen van gegevens voor databases in een beschikbaarheidsgroep kan worden onderbroken. Daarnaast kunt u foutberichten van de volgende strekking in het foutenlogboek van SQL Server ontvangen:
DateTime spid# AlwaysOn Availability Groups gegevensverplaatsing voor database 'SSISDB' is om de volgende reden onderbroken: 'system' (Bron-id #; Brontekenreeks: '#'). Als u de gegevensverplaatsing in de database wilt hervatten, moet u de database handmatig hervatten. Zie SQL Server Books Online voor informatie over het hervatten van een beschikbaarheidsdatabase.
Fout: 3313, ernst: 21, toestand: 2.
DateTime spid# Tijdens het opnieuw uitvoeren van een geregistreerde bewerking in database 'SSISDB' is een fout opgetreden bij de logboekrecord-id (638:319687:1). Normaal gesproken wordt de specifieke fout eerder geregistreerd als een fout in het foutenlogboek van het besturingssysteem. Zet de database terug vanaf een volledige back-up of repareer de database.
Status
Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in het gedeelte 'Van toepassing op'.
Oplossing
Dit probleem is opgelost in de volgende cumulatieve update voor SQL Server:
Over cumulatieve updates voor SQL Server:
Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. Bekijk de meest recente cumulatieve updates voor SQL Server:
Meer informatie
Meer informatie over de terminologie die Microsoft gebruikt om software-updates te beschrijven.