KB4548001 - FIX: er treedt een verbindingsfout op wanneer u verbinding probeert te maken met SQL Server 2017 op Linux met behulp van OpenSSL 1.1

Van toepassing op
SQL Server 2017 Enterprise on Linux SQL Server 2017 Enterprise Core on Linux SQL Server 2017 Standard on Linux SQL Server 2017 Developer Linux

Symptomen

Wanneer u probeert verbinding te maken met SQL Server 2017 voor Linux op een distributie waarvoor OpenSSL 1.1 is geconfigureerd en OpenSSL 1.0 niet is geïnstalleerd, wordt een verbindingsfoutbericht van de volgende strekking weergegeven:

Er is verbinding gemaakt met de server, maar er is een fout opgetreden tijdens het aanmeldingsproces. (provider: SSL Provider, error:0 - een bestaande verbinding is geforceerd afgesloten door de externe host.)
      

Bijvoorbeeld: Als u verbinding probeert te maken met SQLCMD, worden mogelijk de volgende foutberichten weergegeven:

Sqlcmd: Fout: Microsoft ODBC-stuurprogramma 17 voor SQL Server : TCP-provider: foutcode 0x2746.

Sqlcmd: Fout: Microsoft ODBC-stuurprogramma 17 voor SQL Server : Client kan geen verbinding tot stand brengen.

Opmerking: Een voorbeeld van een Linux-distributie die wordt geleverd met OpenSSL 1.1 en zonder OpenSSL 1.0 is Red Hat Enterprise Linux 8.0.

Status

Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in het gedeelte 'Van toepassing op'.

Oplossing

Dit probleem is opgelost in de volgende cumulatieve update voor SQL Server:

Over cumulatieve updates voor SQL Server:

Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. Bekijk de meest recente cumulatieve updates voor SQL Server:

Meer informatie

Meer informatie over de terminologie die Microsoft gebruikt om software-updates te beschrijven.