Sintomi
Un'istruzione DDL (Data Definition Language) di lunga durata può bloccare l'attività Tuple Mover in background e causare un deadlock. Molto probabilmente, il compito del Tuple Mover sarà scelto come vittima dello stallo. In questo caso, Microsoft SQL Server potrebbe arrestarsi in modo anomalo. Vengono inoltre visualizzati messaggi di errore simili ai seguenti nel log degli errori di SQL Server:
Nota
Errore: 1205, gravità: 13, stato: 18.
La transazione (ID <processo, ID> processo) è stata bloccata sulle risorse di blocco con un altro processo ed è stata scelta come vittima del deadlock. Eseguire nuovamente la transazione.
ex_terminator: possibile terminazione a causa di un'eccezione durante lo svolgimento dello stack.
Analogamente, quando l'attività Tuple Mover viene eseguita in condizioni di utilizzo elevato della memoria (ad esempio, l'utilizzo della memoria diventa del 100%), l'attività Tuple Mover termina in modo imprevisto e ciò causa l'arresto anomalo di SQL Server.
Risoluzione
Informazioni sull'aggiornamento cumulativo
La correzione di questo problema è inclusa nel seguente aggiornamento cumulativo per SQL Server:
Informazioni sugli aggiornamenti cumulativi per SQL Server
Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:
Aggiornamento cumulativo più recente per SQL Server 2016
Stato
Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".
Riferimenti
Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.