Sintomi
Si supponga di usare Microsoft SQL Server 2016. Quando si esegue il comando ALTER per modificare la configurazione dell'ambito del database e usare anche il fn_dblog funzione per recuperare le righe modificate del database, è possibile che venga visualizzato un errore di asserzione. Ecco uno dei comandi per modificare il parametro di configurazione con ambito database.
ALTER DATABASE SCOPED CONFIGURATION SET PARAMETER_SNIFFING = Off;
Inoltre, i messaggi simili ai seguenti vengono registrati nel log degli errori di SQL Server.
< DateTime> spid<n> Utilizzo della versione 'dbghelp.dll' '4.0.5'
< DateTime> spid<n> **Dump thread - spid = 0, EC = 0x0000028909775730
< DateTime> spid<n> ***Stack Dump inviato a <FilePath\FileName>\SQLDump<nnnnn>.txt
< DateTime> spid<n> * *******************************************************************************
< DateTime> spid<n> *
< DateTime> spid<n> * INIZIA IL DUMP DELLO STACK:
< DateTime> spid<n> * <DateTime> spid <SPID>
< DateTime> spid<n> *
< DateTime> spid<n> * Posizione: medutil.cpp:LineNumber
< DateTime> spid<n> * Espressione: FALSO
< DateTime> spid<n> * spid: < SPID>
< DateTime> spid<n> * ID processo: <PID>
< DateTime> spid<n> * Descrizione: Valore di commutazione non valido
Stato
Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".
Risoluzione
Questo problema è stato risolto nel seguente aggiornamento cumulativo per SQL Server:
Informazioni sugli aggiornamenti cumulativi per SQL Server:
Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:
Riferimenti
Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.