Sintomi
Quando si utilizza SQL SQL Server 2016, considerare lo scenario seguente:
- Viene creato un indice columnstore cluster in una tabella ottimizzata per la memoria che contiene una colonna di stringa con tipo di dati, ad esempio nchar o nvarchar.
- La lunghezza dei dati della colonna è di 32 byte, ad esempio nchar(16) o nvarchar(16)).
- I dati nella colonna sono univoci o quasi univoci e la dimensione dei dati è di 32 byte.
In questo scenario, quando si inseriscono dati in questa tabella, è possibile che venga visualizzato il seguente errore di asserzione nel log degli errori di SQL Server:
Nota
vldPageCount <= SegmentsTableRow::MaxSerializedPages
Risoluzione
Questo problema è stato risolto negli aggiornamenti cumulativi seguenti per SQL Server:
Avvertenza Dopo aver installato l'aggiornamento, è necessario impostare il flag di traccia 9968 per abilitare la correzione. Per impostare il flag di traccia 9968, vedere l'argomento Flag di traccia (Transact-SQL) nel sito Web Microsoft Developer Network (MSDN).
Informazioni sugli aggiornamenti cumulativi per SQL Server
Ogni nuova build di SQL Server 2016 contiene tutte le correzioni rapide e di sicurezza incluse nella build precedente. È consigliabile installare gli aggiornamenti cumulativi più recenti per SQL Server:
Aggiornamento cumulativo più recente per SQL Server 2016
Stato
Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".
Riferimenti
Informazioni sulla terminologia utilizzata da Microsoft per descrivere gli aggiornamenti software.