KB2938460 - FIX: er is sprake van een toegangsfout wanneer u datepart (weekdag) probeert te gebruiken in een systeemeigen gecompileerde opgeslagen procedure in SQL Server 2014

Van toepassing op
SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Symptomen

Stel dat u Microsoft SQL Server 2014 gebruikt. Wanneer u datepart (weekdag) probeert te gebruiken in een systeemeigen gecompileerde opgeslagen procedure, treedt er een toegangsfout op en wordt de verbinding verbroken. Bovendien wordt het volgende foutbericht weergegeven:

Opmerking

Er is een ernstige fout opgetreden in de huidige opdracht. De resultaten, indien aanwezig, moeten worden genegeerd.

Oorzaak

Het probleem treedt op vanwege een defect in SQL Server 2014.
Als u datepart gebruikt met een char-argument, wordt er impliciet geconverteerd naar datetimeoffset. Systeemeigen opgeslagen procedure biedt geen ondersteuning voor datetimeoffset.

Oplossing

Nadat de hotfix is toegepast, brengt SQL Server een wijziging aan om nieuwe logica te introduceren om het char-argument te converteren naar datetime2 voor de native opgeslagen procedure en datetimeoffset voor een normale opgeslagen procedure en constant vouwen.
Het probleem werd voor het eerst opgelost in de volgende cumulatieve update van SQL Server.

Cumulatieve update 1 voor SQL Server 2014 /nl-nl/help/2931693

Informatie over cumulatieve updates voor SQL Server

Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. Bekijk de meest recente cumulatieve updates voor SQL Server:

      

Tijdelijke oplossing

Converteer expliciet naar een ondersteund datetime-type om dit probleem te omzeilen.

Status

Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in het gedeelte 'Van toepassing op'.