KB3035165 - FIX: Fout 8646 wanneer u DML-instructies uitvoert op een tabel met een geclusterde columnstore-index in SQL Server 2014

Van toepassing op
SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Symptomen

Stel dat u een tabel hebt met de geclusterde columnstore-index in Microsoft SQL Server 2014. Wanneer u DML-instructies zoals een update of een delete uitvoert op de tabel, wordt het volgende foutbericht weergegeven en wordt een geheugendumpbestand gegenereerd:

Opmerking

Fout: 8646, Ernst: 21, Toestand: 1.
Kan geen indexvermelding vinden in index-id 1, van tabel-id><, in database '<database>'. De aangegeven index is beschadigd of er is een probleem met het huidige updateplan. Voer DBCC CHECKDB of DBCC CHECKTABLE uit. Als het probleem zich blijft voordoen, neemt u contact op met de productondersteuning.

Oplossing

Servicepack informatie

Om dit probleem op te lossen, downloadt u Service Pack 1 voor SQL Server 2014.

Voor meer informatie over SQL Server 2014 Service Pack 1 (SP1) raadpleegt u de fouten die zijn verholpen in SQL Server 2014 Service Pack 1.

Informatie over cumulatieve update

Het probleem werd voor het eerst opgelost in de volgende cumulatieve update van SQL Server.

Aanbeveling: Installeer de meest recente cumulatieve update voor SQL Server

Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. We raden u aan de meest recente cumulatieve updates voor SQL Server te downloaden en te installeren:

      

Status

Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in het gedeelte 'Van toepassing op'.