Symptomen
Dit probleem treedt op wanneer u DML-instructies (Data Manipulation Language) uitvoert op tabellen die geclusterde columnstore-indexen bevatten. Wanneer dit probleem zich voordoet, ziet u in de sys.column_store_row_groups Dynamic Management View (DMV) veel nieuwe posten waarvan de delta_store_hobt_id kolom geen null-waarden bevat en de kolom met totalen rijen kleine getallen bevat. Mogelijk wordt ook het volgende foutbericht weergegeven:
Opmerking
Niet-renderende taak gedetecteerd in function = <FunctionName>::Get file = line = <LineNumber>
Bovendien wordt een gerelateerd dumpbestand gegenereerd.
Oplossing
Servicepack informatie
Om dit probleem op te lossen, downloadt u Service Pack 1 voor SQL Server 2014.
Voor meer informatie over SQL Server 2014 Service Pack 1 (SP1) raadpleegt u de fouten die zijn verholpen in SQL Server 2014 Service Pack 1.
Informatie over cumulatieve updates
Dit probleem werd voor het eerst opgelost in de volgende cumulatieve update van SQL Server.
Cumulatieve update 5 voor SQL Server 2014 /nl-nl/help/3011055
Informatie over cumulatieve updates voor SQL Server
Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. Bekijk de meest recente cumulatieve updates voor SQL Server:
Meer informatie
Dit probleem treedt op omdat met elke update- of verwijderinstructie alle delta-archieven worden vergrendeld. Wanneer alle delta-stores zijn vergrendeld, wordt met een insert-instructie een nieuw delta-archief gemaakt. Deze hotfix probeert alleen de delta-opslagplaatsen te vergrendelen die worden beïnvloed door bijwerken of verwijderen en maakt nieuwe delta-opslagplaatsen minder snel als er al veel delta-opslagplaatsen open zijn.
Status
Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in het gedeelte 'Van toepassing op'.