FIX: kan geen geïndexeerde weergave maken voor een geclusterde columnstore-index en BCP voor de tabel mislukt in SQL Server 2014

Van toepassing op
SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Symptomen

Stel dat u een gepartitioneerde tabel hebt met een geclusterde columnstore-index in Microsoft SQL Server 2014 en dat er enkele gegevens in de tabel staan. Wanneer u probeert een geïndexeerde weergave voor de tabel te maken, wordt het volgende foutbericht weergegeven:

Opmerking

Interne queryprocessorfout: de queryprocessor kan geen toegang krijgen tot een vereiste interface.

Als u de gegroepeerde columnstore-index maakt nadat u de geïndexeerde weergave hebt gemaakt, treedt het probleem niet op. Wanneer u echter BCP (Bulk Copy) probeert uit te voeren op de tabel, mislukt de bewering als de tabel het gegevenstype char, nchar, varchar, nvarchar of varbinary bevat.

Oplossing

Het probleem werd voor het eerst opgelost in de volgende cumulatieve update van SQL Server.

Cumulatieve update 3 voor SQL Server 2014 /nl-nl/help/2984923

Informatie over cumulatieve updates voor SQL Server

Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. Bekijk de meest recente cumulatieve updates voor SQL Server:

      

Status

Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in het gedeelte 'Van toepassing op'.