Symptômes
Prenons le scénario suivant :
- Vous avez installé le cluster de basculement Microsoft SQL Server 2014 instance sur un nœud.
- Vous utilisez le nom instance dans SQL Server moteur de base de données et SQL Server Reporting Services (SSRS).
- Vous démarrez SSRS avant de démarrer le moteur de base de données SQL Server.
- Vous ajoutez un deuxième nœud dans le cluster de basculement.
Dans ce scénario, vous ne pouvez pas déplacer la ressource SQL Server du premier nœud vers le deuxième nœud. En outre, le message d’erreur suivant peut s’afficher :
Remarque
Erreur de serveur : 8310、Gravité : 16、État : 1。
Serveur impossible de créer (ou d’ouvrir) l’objet de mappage de fichier nommé « Global\SQL_110_MEMOBJ_24_MSSQLSERVER_0 ». Les compteurs de performance SQL Server sont désactivés.
Erreur de serveur : 3409、Gravité : 16、État : 1。
Échec de la configuration de la mémoire partagée du compteur de performances du serveur avec l’erreur -1. Réinstallez sqlctr.ini pour ce instance et assurez-vous que le compte de connexion instance dispose des autorisations de Registre correctes.
Résolution
Le problème a été résolu pour la première fois dans la mise à jour cumulative suivante de SQL Server.
Mise à jour cumulative 2 pour SQL Server 2014 /en-us/help/2967546
À propos des mises à jour cumulatives pour SQL Server
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».