KB4510934 - CORRECTIF : Une utilisation non transactionnelle prolongée de FileTable sans redémarrage instance peut entraîner une erreur du planificateur ou un plantage du serveur sans rendement dans les SQL Server 2014, 2016 et 2017

S’applique à
SQL Server 2014 Service Pack 2 - duplicate (do not use) SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Enterprise Core - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use) SQL Server 2017 Developer on Windows SQL Server 2017 Enterprise Core on Windows SQL Server 2017 Enterprise on Windows SQL Server 2017 Standard Windows

Symptômes

Supposons que FileTable soit utilisé par les API d’E/S de fichier dans une condition de trafic élevé pendant une très longue période sans instance redémarrage. Dans ce scénario, vous pouvez rencontrer une erreur de planification sans rendement, une utilisation de 100 % du processeur ou un plantage du serveur. Ce problème se produit lorsqu’une requête utilisateur atteint une boucle infinie en interne.

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Résolution

Ce problème est résolu dans les mises à jour cumulatives suivantes pour SQL Server :

À propos des mises à jour cumulatives pour SQL Server :

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

Références

En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.