Symptômes
Lorsque vous exécutez plusieurs opérations non liées à la croissance de fichiers, telles qu’une sauvegarde dans Microsoft SQL Server 2014, 2016 ou 2017, les opérations peuvent utiliser tout l’espace disque et l’espace n’est pas suffisant pour la croissance critique du journal. Étant donné que la base de données ne peut pas créer plus d’espace journal, les modifications de la base de données et la synchronisation avec les bases de données secondaires échouent, la récupération échoue et la base de données ne peut pas être mise en ligne. En outre, un ou plusieurs des messages d’erreur suivants peuvent s’afficher :
-
Remarque
Erreur 9002, Gravité : 17, État : 9.
Le journal des transactions de la base de données « DatabaseName » est saturé en raison de la valeur « AVAILABILITY_REPLICA » -
Remarque
Avertissement 3052 : Msg 3052, Niveau 16, État 1, Ligne LineNumber
BACKUP LOG n’a pas pu enregistrer les mises à jour pour la base de données « DatabaseName ».
Des sauvegardes de journal ultérieures seront nécessaires pour faire passer le point de sauvegarde de « LSNID1 » à « LSNID2 » une fois que l’espace de journal sera disponible pour la journalisation. -
Remarque
Erreur 3314
Lors de l’annulation d’une opération journalisée dans la base de données « DatabaseName », une erreur s’est produite au niveau de l’ID d’enregistrement de journal %S_LSN. En règle générale, l’échec spécifique est consigné précédemment comme une erreur dans le service Journal des événements Windows. Restaurez la base de données ou le fichier à partir d’une sauvegarde, ou réparez la base de données.
Résolution
Ce correctif est inclus dans les mises à jour cumulatives suivantes pour SQL Server :
Mise à jour cumulative 1 pour SQL Server 2016 SP2
Mise à jour cumulative 5 pour SQL Server 2017
Mise à jour cumulative CU 38 pour SQL Server 2016 SP1
Mise à jour cumulative 11 pour SQL Server 2014 SP2
À propos des mises à jour cumulatives pour SQL Server :
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :
Dernière mise à jour cumulative pour SQL Service 2017
Dernière mise à jour cumulative pour SQL Server 2016
Dernière mise à jour cumulative pour SQL Server 2014
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Références
En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.