Symptômes
Prenons le scénario suivant :
- Vous disposez d’un groupe de disponibilité Always On avec des centaines de bases de données dans Microsoft SQL Server 2014 ou 2016.
- Vous exécutez de lourdes charges de travail dans ce groupe de disponibilité.
- Un basculement du groupe de disponibilité se produit.
Dans ce cas, les bases de données du groupe de disponibilité au niveau de la nouvelle réplica principale peuvent apparaître comme ne se synchronisant pas en raison de la longueur des opérations d’annulation, et les bases de données du groupe de disponibilité au niveau de la nouvelle réplica secondaire peuvent apparaître comme étant en cours d’initialisation/synchronisation après le basculement en raison de la gestion des messages entre les réplicas. En outre, les messages d’erreur semblables aux suivants sont consignés dans le journal des erreurs de SQL Server :
Remarque
Erreur : 35278, Gravité : 17, État : 4.
La base de données de disponibilité database_name, qui se trouve dans le rôle secondaire, est en cours de redémarrage pour se resynchroniser avec ResyncWithPrimary - Endommagé [9] - EOL : 00000047:00000F58:0001 Récupération : FFFFFFFF :FFFFFFFF :0001 Annuler : 00000047:00000F70:005F Base de données primaire actuelle. Ceci n’est qu’un message d’information. Aucune action de l’utilisateur n’est requise.
ResyncWithPrimary - Aucune annulation nécessaire [9] - EOL : 00000047:00000F58:0001 Recovery : FFFFFFFF :FFFFFFFF :0001 Undo : 00000047:00000F70:005F
Résolution
Ce problème est résolu dans les mises à jour cumulatives suivantes pour SQL Server :
Mise à jour cumulative 5 pour SQL Server 2016 RTM
Mise à jour cumulative 2 pour SQL Server 2016 SP1
Mise à jour cumulative 3 pour SQL Server 2014 Service Pack 2
À propos des mises à jour cumulatives pour SQL Server
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :
Dernière mise à jour cumulative pour SQL Server 2016
Dernière mise à jour cumulative pour SQL Server 2014
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Références
Découvrez la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.