KB4475322 – CORRECTIF : l’erreur « non cédant » se produit lorsqu’il y a une utilisation intensive d’instructions préparées en SQL Server 2014, 2016 et 2017

S’applique à
SQL Server 2014 Service Pack 2 - duplicate (do not use) SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Enterprise Core - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2016 Service Pack 1 SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use)

Symptômes

Supposons que vous utilisez une application pour vous connecter à une instance de Microsoft SQL Server 2014, 2016 et 2017. En cas d’utilisation intensive de la procédure stockée (SP) sp_prepare qui n’est pas immédiatement suivie de sp_unprepare, de nombreuses entrées mises en cache de descripteur SQL sont générées. En outre, une erreur de planificateur non cédant peut apparaître dans le journal des erreurs.

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Résolution

Ce problème est résolu dans les mises à jour cumulatives suivantes pour SQL Server :

À propos des mises à jour cumulatives pour SQL Server :
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

Références

En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.