Sintomi
Si consideri lo scenario seguente:
- Microsoft SQL Server 2014 è installato in un computer.
- È possibile creare statistiche incrementali nella tabella.
- Unisci le partizioni della tua tabella più volte per ridurre il numero delle partizioni di almeno 2.
- Le statistiche incrementali vengono aggiornate manualmente o vengono aggiornati dati sufficienti per attivare l'aggiornamento automatico delle statistiche compilando una query.
In questo scenario si verifica una violazione di accesso. Viene anche visualizzato l'errore seguente:
Nota
Si è verificato un errore grave nel comando corrente. I risultati, se presenti, devono essere scartati.
Risoluzione
Il problema è stato risolto per la prima volta nell'aggiornamento cumulativo seguente di SQL Server.
Aggiornamento cumulativo 1 per SQL Server 2014 /it-it/help/2931693
Informazioni sugli aggiornamenti cumulativi per SQL Server
Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:
Stato
Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".