Sintomi
Si consideri lo scenario seguente:
- Si dispone di un database OLTP In-Memory in Microsoft SQL Server 2014.
- Si abilita Transparent Data Encryption (TDE) nel database.
- Si disabilita TDE e si eliminano tutte le chiavi di crittografia e i certificati.
- Si tenta di rendere il database offline.
In questo scenario non è possibile portare offline il database e nemmeno è necessario un ripristino del log. Viene anche visualizzato il messaggio di errore seguente:
Nota
Messaggio 33111, livello 16, stato 3, riga 37
Impossibile trovare il certificato server con l'identificazione personale '0xA4818012ECFD38A0C1A73298B8A0460F6C261392'.
Messaggio 5181, livello 16, stato 5, riga 37
Impossibile riavviare il database "<Nome database>". Ripristino dello stato precedente.
Messaggio 5069, livello 16, stato 1, riga 37
Istruzione ALTER DATABASE non riuscita.
Messaggio 9016, livello 21, stato 7, riga 37
Si è verificato un errore durante l'elaborazione del log per il database "<Nome> database". Impossibile decrittografare il blocco di log.
Messaggio 3414, livello 21, stato 1, riga 37
Si è verificato un errore durante il ripristino, impedendo il database "<Nome database>". (x:y) dal riavvio. Diagnosticare gli errori di ripristino e correggerli o eseguire il ripristino da un backup valido noto. Se gli errori non vengono corretti o sono previsti, contattare il supporto tecnico.
Risoluzione
Il problema è stato risolto per la prima volta nell'aggiornamento cumulativo seguente di SQL Server.
Aggiornamento cumulativo 4 per SQL Server 2014 /it-it/help/2999197
Informazioni sugli aggiornamenti cumulativi per SQL Server
Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:
Stato
Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".