KB2974376 - FIX: Errore durante l'esecuzione di una stored procedure che inserisce record nella tabella temp per la seconda volta in SQL Server 2014

Si applica a
SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Sintomi

Si supponga di disporre di una stored procedure in grado di creare una tabella temporanea e inserire record nella tabella con SET IDENTITY_INSERT ON in Microsoft SQL Server 2014. La tabella creata dalla procedura contiene un campo Identity e quest'ultimo è indicizzato. Quando si esegue la procedura per la seconda volta, si verifica una violazione di accesso. Viene anche visualizzato l'errore seguente:

Nota

Messaggio 0, Livello 11, Stato 0, Riga 0
Si è verificato un errore grave nel comando corrente.  I risultati, se presenti, devono essere scartati.
Messaggio 0, livello 20, stato 0, riga 0
Si è verificato un errore grave nel comando corrente.  I risultati, se presenti, devono essere scartati.

Risoluzione

Il problema è stato risolto per la prima volta nell'aggiornamento cumulativo seguente di SQL Server.

Aggiornamento cumulativo 2 per SQL Server 2014 /it-it/help/2967546

Informazioni sugli aggiornamenti cumulativi per SQL Server

Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:

      

Soluzione alternativa

Per risolvere questo problema, rimuovere l'indice nel campo Identity.

Stato

Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".