Sintomi
Si supponga di disporre di tabelle con indici columnstore cluster in Microsoft SQL Server 2014. Quando si esegue una query contenente più istruzioni di inserimento in blocco in queste tabelle, viene visualizzato il messaggio di errore seguente:
Nota
Posizione: qquery.cpp:1617
Espressione: NULL == pxteColumnStoreBulkInsert
SPIID: 300
ID processo: 1704
Messaggio 3624, livello 20, stato 1, riga 1
Controllo dell'asserzione di sistema non riuscito. Per informazioni dettagliate, controllare il log degli errori di SQL Server. In genere, un errore di asserzione è causato da un bug del software o da un danneggiamento dei dati. Per verificare il danneggiamento del database, è consigliabile eseguire DBCC CHECKDB. Se hai accettato di inviare dump a Microsoft durante l'installazione, verrà inviato un mini dump a Microsoft. Un aggiornamento potrebbe essere disponibile da Microsoft nel Service Pack più recente o in un hotfix dal supporto tecnico.
Risoluzione
Informazioni sull'aggiornamento cumulativo
Il problema è stato risolto per la prima volta nell'aggiornamento cumulativo seguente di SQL Server.
Consiglio: installare l'aggiornamento cumulativo più recente per SQL Server
Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. È consigliabile scaricare e installare gli aggiornamenti cumulativi più recenti per SQL Server:
- Aggiornamento cumulativo più recente per SQL Server 2014 SP1
- Aggiornamento cumulativo più recente per SQL Server 2014
Stato
Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".