Sintomi
Problema 1:
Si consideri lo scenario seguente:
- È possibile usare la procedura guidata Aggiungi replica al gruppo di disponibilità per aggiungere una replica di Azure al gruppo di disponibilità AlwaysOn in Microsoft SQL Server 2014.
- Nella sottoscrizione di Windows Azure non sono configurati gruppi di affinità.
- L'ID sottoscrizione di Windows Azure è stato immesso nell'Installazione guidata Replica di Azure.
In questo scenario, l'Installazione guidata Azure Replica non è in grado di enumerare l'elenco di Azure Rete virtuale nella casella di riepilogo a discesa Rete virtuale.
Problema 2:
Si supponga che si tenti di usare la procedura guidata Aggiungi replica al gruppo di disponibilità per aggiungere una replica di Azure al gruppo di disponibilità AlwaysOn in Microsoft SQL Server 2014. Quando si esegue il provisioning di una macchina virtuale di Azure, potrebbe verificarsi un errore all'inizio della creazione di una nuova macchina virtuale di Azure (nessuna macchina virtuale viene effettivamente creata nella sottoscrizione) e viene visualizzato il messaggio di errore seguente:
Nota
Tentando di eseguire il provisioning della macchina virtuale di Windows Azure 'vmname' si è verificato un errore. (Microsoft.SQLServer.Management.HadrTasks)
Informazioni aggiuntive:
OperationID:1190164893f0120f97861e2cd5c47c8f, status=Failed, Code=400, details=Il vincolo di geolocalizzazione specificato per il servizio ospitato non è valido.
(Microsoft.SQLServer.Management.HadrTasks)
Risoluzione
Il problema è stato risolto per la prima volta nell'aggiornamento cumulativo seguente di SQL Server.
Aggiornamento cumulativo 5 per SQL Server 2014 /it-IT/help/3011055
Informazioni sugli aggiornamenti cumulativi per SQL Server
Ogni nuovo aggiornamento cumulativo per SQL Server contiene tutte le correzioni rapide e di sicurezza incluse nell'aggiornamento cumulativo precedente. Vedere gli aggiornamenti cumulativi più recenti per SQL Server:
Informazioni sull'aggiornamento rapido (hotfix)
Aggiornamento rapido per SQL Server 2014 Un aggiornamento rapido supportato è disponibile da Microsoft. Tuttavia, questo aggiornamento rapido (hotfix) ha lo scopo di correggere solo il problema descritto in questo articolo. Applica questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico.
Se l'hotfix è disponibile per il download, c'è una sezione "Download di hotfix disponibile" all'inizio di questo articolo della Knowledge Base. Se questa sezione non viene visualizzata, inviare una richiesta al servizio clienti e supporto tecnico Microsoft per ottenere l'aggiornamento rapido (hotfix).
Nota: se si verificano ulteriori problemi o se è necessaria una risoluzione dei problemi, potrebbe essere necessario creare una richiesta di assistenza separata. I normali costi di supporto verranno applicati alle domande di supporto aggiuntive e ai problemi che non si qualificano per questo aggiornamento rapido specifico. Per un elenco completo dei numeri di telefono del servizio clienti e del supporto tecnico Microsoft o per creare una richiesta di servizio separata, visita il seguente sito Web Microsoft:
/contactus/?ws=support Nota: nel modulo "Download dell'aggiornamento rapido disponibile" vengono visualizzate le lingue per cui è disponibile l'aggiornamento rapido (hotfix). Se la lingua non è visualizzata, è perché non è disponibile un aggiornamento rapido (hotfix).
Altre informazioni
L'allocazione di una nuova rete virtuale di Azure è ora definita in un'area e non più definita tramite un gruppo di affinità. L'Aggiunta guidata Replica di Azure enumera le reti virtuali di Azure tramite Affinity Group. Pertanto, la procedura guidata non può visualizzare le reti virtuali di Azure nell'elenco a discesa Rete virtuale nella finestra di dialogo Aggiungi replica di Azure della procedura guidata Aggiungi replica di Azure.
Stato
Microsoft ha confermato che si tratta di un problema relativo ai prodotti elencati nella sezione "Si applica a".