استيراد أو تصدير الملفات النصية (.txt أو csv.)

ينطبق على
Excel لـ Microsoft 365 Excel 2024 Excel 2021 Excel 2019 Excel 2016

هناك طريقتان لاستيراد البيانات من ملف نصي باستخدام Excel: يمكنك فتحه في Excel، أو يمكنك استيراده كنطاق بيانات خارجية. لتصدير البيانات من Excel إلى ملف نصي، استخدم الأمر "حفظ باسم " وغير نوع الملف من القائمة المنسدلة.

هناك تنسيقان شائعا الاستخدام للملفات النصية:

  • الملفات النصية المحددة (.txt)، التي يفصل فيها حرف TAB (رمز حرف ASCII 009) عادة كل حقل من الحقول النصية.
  • الملفات النصية (.csv التي تفصلها الفاصلة، والتي تفصل فيها الفاصلة (،) كل حقل من الحقول النصية.

يمكنك تغيير حرف الفاصل المستخدم في كل من الملفات النصية المحددة والملفات النصية .csv. قد يكون هذا ضروريا للتأكد من أن عملية الاستيراد أو التصدير تعمل بالطريقة التي تريدها.

ملاحظة

يمكنك استيراد ما يصل إلى 1048576 صفا و16384 عمودا أو تصديرها.

استيراد ملف نصي عن طريق فتحه في Excel

يمكنك فتح ملف نصي أنشأته في برنامج آخر كمصنف Excel باستخدام الأمر "فتح". لا يؤدي فتح ملف نصي في Excel إلى تغيير تنسيق الملف — يمكنك رؤية ذلك في شريط عنوان Excel، حيث يحتفظ اسم الملف بملحق اسم الملف النصي (على سبيل المثال، .txt أو .csv).

  1. الانتقال إلى ملف>فتح واستعرض وصولا إلى الموقع الذي يحتوي على الملف النصي.

  2. حدد Text Files في القائمة المنسدلة لنوع الملف في مربع الحوار "فتح".

  3. حدد موقع الملف النصي الذي تريد فتحه ثم انقر نقرا مزدوجا فوقه.

    • إذا كان الملف عبارة عن ملف نصي (.txt)، يبدأ Excel بتشغيل "معالج استيراد النص". عندما تنتهي من تنفيذ الخطوات، انقر فوق "إنهاء" لإكمال عملية الاستيراد. راجع معالج استيراد النص لمزيد من المعلومات حول المحددات والخيارات المتقدمة.

    • إذا كان الملف عبارة عن ملف .csv، فإن Excel يفتح تلقائيا الملف النصي ويعرض البيانات في مصنف جديد.

      ملاحظة

      عندما يفتح Excel ملف .csv، فإنه يستخدم إعدادات تنسيق البيانات الافتراضية الحالية لتفسير كيفية استيراد كل عمود من البيانات. إذا كنت تريد المزيد من المرونة في تحويل الأعمدة إلى تنسيقات بيانات مختلفة، يمكنك استخدام "معالج استيراد النص". على سبيل المثال، قد يكون تنسيق عمود البيانات في ملف .csv MDY، ولكن تنسيق البيانات الافتراضي في Excel هو YMD، أو تريد تحويل عمود من الأرقام يحتوي على أصفار بادئة إلى نص حتى تتمكن من الاحتفاظ بالأصفار البادئة. لإجبار Excel على تشغيل "معالج استيراد النص"، يمكنك تغيير ملحق اسم الملف من .csv إلى .txt قبل فتحه، أو يمكنك استيراد ملف نصي من خلال الاتصال به (لمزيد من المعلومات، راجع القسم التالي).

استيراد ملف نصي عن طريق الاتصال به

يمكنك استيراد بيانات من ملف نصي إلى ورقة عمل موجودة.

  1. انقر فوق الخلية التي تريد وضع البيانات فيها من الملف النصي.

  2. على علامة التبويب " بيانات "، في المجموعة "الحصول على & تحويل البيانات "، انقر فوق "من نص/CSV".

  3. في مربع الحوار "استيراد البيانات "، حدد موقع الملف النصي الذي تريد استيراده وانقر نقرا مزدوجا فوقه، ثم انقر فوق "استيراد".
    اتبع الإرشادات في "معالج استيراد النص". انقر فوق صورة الزر"تعليمات" في أي صفحة من "معالج استيراد النص" للحصول على مزيد من المعلومات حول استخدام المعالج. عندما تنتهي من تنفيذ الخطوات الواردة في المعالج، انقر فوق "إنهاء " لإكمال عملية الاستيراد.

  4. بعد تحديد الجدول، حدد تحميل > إلى، لتحديد المكان الذي تريد وضع البيانات فيه. في مربع الحوار "استيراد بيانات "، قم بما يلي:

    1. حدد أحد الخيارات الموجودة في مربع الحوار "استيراد بيانات ".
    2. انقر فوق موافق.
      يضع Excel نطاق البيانات الخارجية في الموقع الذي تحدده.

إذا لم يحول Excel عمود بيانات إلى التنسيق الذي تريده، فيمكنك تحويل البيانات بعد استيرادها. لمزيد من المعلومات، راجع تحويل الأرقام المخزنة كنص إلى أرقاموتحويل التواريخ المخزنة كنص إلى تواريخ.

تصدير بيانات إلى ملف نصي عن طريق حفظها

يمكنك تحويل ورقة عمل Excel إلى ملف نصي باستخدام الأمر "حفظ باسم ".

  1. انتقل إلى ملف>حفظ باسم.

  2. يظهر مربع الحوار حفظ باسم.

  3. في المربع حفظ بنوع ، اختر تنسيق الملف النصي لورقة العمل.

    • على سبيل المثال، انقر فوق Text (Tab delimited) أو CSV (Comma delimited).
    • ملاحظة

      تدعم التنسيقات المختلفة مجموعات ميزات مختلفة. لمزيد من المعلومات حول مجموعات الميزات التي تعتمدها تنسيقات الملفات النصية المختلفة، راجع تنسيقات الملفات المعتمدة في Excel.

  4. استعرض وصولا إلى الموقع الذي تريد حفظ الملف النصي الجديد فيه، ثم انقر فوق حفظ.

  5. يظهر مربع حوار يذكرك بأنه سيتم حفظ ورقة العمل الحالية فقط في الملف الجديد. إذا كنت متأكدا من أن ورقة العمل الحالية هي التي تريد حفظها كملف نصي، فانقر فوق "موافق". يمكنك حفظ أوراق العمل الأخرى كملفات نصية منفصلة عن طريق تكرار هذا الإجراء لكل ورقة عمل.

  6. يظهر مربع حوار ثان لتذكيرك بأنه قد تحتوي ورقة العمل على ميزات لا تعتمدها تنسيقات الملفات النصية. إذا كنت مهتما بحفظ بيانات ورقة العمل في الملف النصي الجديد فقط، فانقر فوق نعم. إذا لم تكن متأكدا من ميزات Excel التي لا تدعمها تنسيقات الملفات النصية وتريد معرفة المزيد عنها، فانقر فوق "تعليمات " للحصول على مزيد من المعلومات.

لمزيد من المعلومات حول حفظ الملفات بتنسيقات أخرى، راجع حفظ مصنف بتنسيق ملف آخر.

تغيير المحدد المستخدم عند استيراد ملف نصي

تختلف الطريقة التي تستخدمها لتغيير المحدد عند الاستيراد باختلاف طريقة استيراد النص.

  • إذا كنت تستخدم Get & Transform Data > From Text/CSV، فاختر حرفا لاستخدامه من القائمة ضمن المحدد، بعد اختيار الملف النصي والنقر فوق استيراد. يمكنك مشاهدة تأثير اختيارك الجديد مباشرة في معاينة البيانات، حتى تتأكد من قيامك بالاختيار الذي تريده قبل المتابعة.
  • إذا كنت تستخدم "معالج استيراد النص" لاستيراد ملف نصي، يمكنك تغيير المحدد المستخدم لعملية الاستيراد في الخطوة 2 من "معالج استيراد النص". في هذه الخطوة، يمكنك أيضا تغيير الطريقة التي يتم بها التعامل مع المحددات المتتالية، مثل علامات الاقتباس المتتالية.
    راجع معالج استيراد النص لمزيد من المعلومات حول المحددات والخيارات المتقدمة.

تغيير فاصل القوائم الافتراضي لحفظ الملفات كنص (.csv) في Excel

إذا كنت تريد استخدام فاصلة منقوطة كفاصل القوائم الافتراضي عند الحفظ باسم .csv، ولكنك تحتاج إلى حصر التغيير ب Excel، فيمكنك تغيير الفاصل العشري الافتراضي إلى فاصلة، وهذا يجبر Excel على استخدام فاصلة منقوطة لفاصل القوائم. من الواضح أن هذا سيغير أيضا طريقة عرض الأرقام العشرية ، لذا ضع في اعتبارك أيضا تغيير فاصل الآلاف للحد من أي لبس.

  1. إلغاء تحديد خيارات> Excelخيارات>التحرير المتقدمة>استخدام فواصل النظام.
  2. قم بتعيين الفاصل العشري إلى , (فاصلة).
  3. تعيين فاصل الآلاف إلى . (نقطة).

تغيير فاصل القوائم الافتراضي للملفات النصية الجديدة (يؤثر على كافة البرامج)

عندما تحفظ مصنفا كملف .csv، تكون فاصلة فاصل القوائم الافتراضي (المحدد). ويمكنك تغييره إلى حرف فاصل آخر باستخدام إعدادات المنطقة في Windows. 

إنذار

سيؤدي تغيير إعداد Windows إلى حدوث تغيير عام على الكمبيوتر الخاص بك، مما يؤثر على جميع التطبيقات. لتغيير المحدد في Excel فقط، راجع تغيير فاصل القوائم الافتراضي لحفظ الملفات كنص (.csv) في Excel.

  1. في Microsoft Windows 11، حدد شريط البحث واكتب إعدادات المنطقة.
  2. حدد إعدادات اللغة الإدارية.
  3. ضمن علامة التبويب التنسيقات ، حدد إعدادات إضافية.
  4. في مربع الحوار "تخصيص التنسيق "، ضمن علامة التبويب "أرقام "، اكتب حرفا لاستخدامه كفاصل جديد في المربع " فاصل القائمة ".
  5. حدد "موافق " مرتين.

ملاحظة

 بعد تغيير حرف فاصل القوائم للكمبيوتر، ستستخدم كافة البرامج الحرف الجديد كفاصل للقائمة. يمكنك تغيير الحرف مرة أخرى إلى الحرف الافتراضي باتباع الإجراء نفسه.

هل تحتاج إلى مزيد من المساعدة؟

يمكنك دائما الاستفسار من أحد الخبراء في مجتمع Excel التقني أو الحصول على الدعم في المجتمعات.

اطلع أيضاً على

استيراد البيانات من مصادر بيانات خارجية (Power Query)