Symptômes
Supposons que vous créez une base de données tabulaire à l’aide de la commande Create ou CreateOrReplace Tabular Model Scripting Language (TMSL) dans Microsoft SQL Server 2016 et que le nom de la base de données est DB1. Ensuite, vous renommez la base de données en DB2. Ensuite, vous créez une autre base de données portant le nom DB1 à l’aide de la même commande Create ou CreateOrReplace TMSL. Dans cette situation, un message d’erreur semblable au suivant s’affiche :
Remarque
La requête DDL JSON a échoué avec l’erreur suivante : Un autre objet « Database » a l’ID< d’ID>.
Remarque : Ce problème ne se produit pas si vous avez défini l’ID de base de données.
Résolution
Ce problème a été résolu dans la mise à jour cumulative de SQL Server suivante :
Recommandation : Installer la dernière mise à jour cumulative pour SQL Server
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Nous vous recommandons de télécharger et d’installer les dernières mises à jour cumulatives pour SQL Server :
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Références
En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.