Symptômes
Supposons que vous utilisez l’amorçage automatique pour initialiser des bases de données réplica secondaires dans Always On groupes de disponibilité (AG). Lorsque vous supprimez une base de données des groupes de disponibilité Always On avant que l’essaimage ne puisse être effectué, vous remarquerez que SQL Server commence à signaler les assertions associées aux opérations d’essaimage automatique ayant échoué. En outre, des messages d’erreur semblables au suivant peuvent s’afficher :
spid# L’ensemencement automatique de la base de données de disponibilité « DatabaseName » dans le groupe de disponibilité « AG » a échoué avec une erreur temporaire. Nouvelle tentative de l’opération.
spid# L’ensemencement automatique de la base de données de disponibilité « DatabaseName » dans le groupe de disponibilité « AG » a échoué avec une erreur temporaire. Nouvelle tentative de l’opération.
Erreur spid# : 3202, Gravité : 16, État : 1.
spid# Échec de l’écriture sur « {FileName} » : 995(L’opération d’E/S a été abandonnée en raison d’une sortie de thread ou d’une demande d’application.)
Erreur spid# : 3271, Gravité : 16, État : 1.
spid# Une erreur d’E/S irrécupérable s’est produite sur le fichier « {FileName} : » 995(L’opération d’E/S a été abandonnée en raison d’une sortie de thread ou d’une demande d’application.).
Erreur spid# : 41169, Gravité : 16, État : 4.
spid# Une erreur s’est produite lors de la tentative d’accès à la base de données du groupe de disponibilité avec l’ID « IDNumber » dans le groupe de disponibilité « AG ». La base de données de disponibilité est introuvable dans la configuration du groupe de disponibilité. Vérifiez que le nom du groupe de disponibilité et l’ID de la base de données de disponibilité sont corrects, puis relancez la commande.
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Résolution
Ce problème est résolu dans les mises à jour cumulatives suivantes pour SQL Server :
À propos des mises à jour cumulatives pour SQL Server :
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :
- Dernière mise à jour cumulative pour SQL Server 2017
- Dernière mise à jour cumulative pour SQL Server 2016
Références
En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.