KB3174088 - CORRECTIF : Erreur 5283 lors de l’exécution de DBCC CHECKDB sur une base de données qui contient un index columnstore non cluster dans SQL Server 2016

S’applique à
SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Express - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use) SQL Server 2016 Web - duplicate (do not use)

Symptômes

Lorsque vous exécutez DBCC CHECKDB sur une base de données qui contient un index columnstore non cluster, vous pouvez recevoir des messages d’erreur semblables au suivant :

Remarque

Msg 5283, Niveau 16, État 1
La case activée Ensemble de lignes croisé sur l’ID d’objet d’index columnstore, l’ID<> d’objet, l’ID< d’index, l’ID d’index, l’ID> de partition, <l’ID> de partition. Déposez et recréez l’index columnstore.
Résultats DBCC pour <le nom de l’index>.
Il y a m lignes dans n pages pour le nom> d’index de l’objet<.
CHECKDB a trouvé 0 erreur d’allocation et n erreurs de cohérence dans le nom> de l’index de la table< (ID <d’objet, ID d’objet>).
Résultats DBCC pour <le nom de la> table. Il y a m lignes dans n pages pour le nom de la table d’objet<>.

        
      

Résolution

Ce problème a été résolu dans la mise à jour cumulative de SQL Server suivante :

Recommandation : Installer la dernière mise à jour cumulative pour SQL Server

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Nous vous recommandons de télécharger et d’installer les dernières mises à jour cumulatives pour SQL Server :

      

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Références

En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.