Symptômes
Supposons que vous utilisez Microsoft SQL Server 2016. Lorsque vous exécutez la commande ALTER pour modifier la configuration de portée de la base de données et que vous utilisez également la fonction fn_dblog pour récupérer les lignes modifiées de la base de données, vous pouvez recevoir une erreur d’assertion. Voici l’une des commandes permettant de modifier le paramètre de configuration de portée de la base de données.
ALTER DATABASE SCOPEED CONFIGURATION SET PARAMETER_SNIFFING = Off ;
En outre, les messages semblables à ceux ci-dessous sont consignés dans le journal des erreurs de SQL Server.
< DateTime> SPID<n> Utilisation de la version « dbghelp.dll », « 4.0.5 »
< DateTime> spid<n> **Dump thread - spid = 0, EC = 0x0000028909775730
< DateTime> spid<n> *** Stack Dump being sent to <FilePath\FileName>\SQLDump<nnnnn>.txt
< DateTime> SPID<n> * *******************************************************************************
< DateTime> SPID<n> *
< DateTime> spid<n> * BEGIN STACK DUMP :
< DateTime> spid<n> * <DateTime>SPID SPID<>
< DateTime> SPID<n> *
< DateTime> spid<n> * Emplacement : medutil.cpp :LineNumber
< DateTime> spid<n> * Expression : FAUX
< DateTime> spid<n> * spid : <SPID>
< DateTime> spid<n> * ID de processus : <PID>
< DateTime> spid<n> * Description : Valeur de commutateur non valide
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Résolution
Ce problème est résolu dans la mise à jour cumulative suivante pour SQL Server :
À propos des mises à jour cumulatives pour SQL Server :
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :
Références
En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.