KB4089324 - CORRECTIF : erreur 15665 lorsque vous appelez sp_set_session_context à plusieurs reprises avec une valeur de clé nulle dans SQL Server 2016 et 2017

S’applique à
SQL Server 2016 Service Pack 1 SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use) SQL Server 2017 Developer SQL Server 2017 Enterprise SQL Server 2017 Enterprise Core

Symptômes

Supposons que vous utilisez Microsoft SQL Server 2016 et 2017. Quand vous exécutez la procédure stockée sp_set_session_context plusieurs fois (par exemple, plus de 10 fois) pour définir le paramètre Valeur KEY avec une valeur NULL, un message d’erreur semblable au suivant peut s’afficher :

Remarque

Msg 15665, Niveau 16, État 1, Procédure sp_set_session_context, Line LineNumber [Batch Start Line LineNumber ]
La valeur n’a pas été définie pour la clé « KeyName » car la taille totale des clés et des valeurs dans le contexte de la session dépasserait la limite de 1 Mo.

Résolution

Ce problème est résolu dans la mise à jour cumulative suivante pour SQL Server :

Mise à jour cumulative 6 pour SQL Server 2017

Mise à jour cumulative CU 38 pour SQL Server 2016 SP1

À propos des mises à jour cumulatives pour SQL Server :

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

Dernière mise à jour cumulative pour SQL Server 2017
        
         Dernière mise à jour cumulative pour SQL Server 2016

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Références

En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.