KB4494805 – CORRECTIF : L’ajout d’une nouvelle publication peut échouer si la base de données de distribution est dans AG et que le classement est défini sur BIN dans SQL Server 2016 et 2017

S’applique à
SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use)

Symptômes

Prenons le scénario suivant :

  • Vous utilisez Microsoft SQL Server 2016 ou 2017 pour l’éditeur, le distributeur et l’abonné.
  • La base de données de distribution fait partie d’un groupe de disponibilité (AG).
  • Vous ajoutez une nouvelle publication à la base de données de distribution dans l’AG.
  • Le classement est défini sur BIN ou respecte la casse.

Dans ce cas, la publication peut échouer et afficher un message d’erreur semblable au suivant :

Erreur 4104, Niveau 16, État 1, Procedure ProcedureName, Line LineNumber

L’identificateur en plusieurs parties « s.job_id » n’a pas pu être lié.

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Résolution

Ce problème est résolu dans les mises à jour cumulatives suivantes pour SQL Server :

À propos des mises à jour cumulatives pour SQL Server :

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

Références

En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.