KB4490136 - CORRECTIF : une erreur d’assertion se produit lorsque vous utilisez sys.dm_exec_query_statistics_xml dans SQL Server 2016 et 2017

S’applique à
SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use) SQL Server 2017 Developer Windows SQL Server 2017 Enterprise Windows SQL Server 2017 Enterprise Core Windows SQL Server 2017 Standard Windows

Symptômes

Supposons que vous utilisez le sys.dm_exec_query_statistics_xml Fonctions de gestion dynamique (DMF) dans Microsoft SQL Server 2016 et 2017. Lorsque la requête exécutée dans l’ID de session ciblée est déjà terminée et que le DMF tente de récupérer le plan d’exécution de la requête en même temps, une erreur d’assertion se produit.

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Résolution

Ce problème est résolu dans les mises à jour cumulatives suivantes pour SQL Server :

À propos des mises à jour cumulatives pour SQL Server :

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

Références

En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.