Symptômes
Supposons que vous utilisez un environnement de groupe de disponibilité AlwaysOn distribué (DAG) dans Microsoft SQL Server 2016 ou 2017. Si un réplica secondaire local est défini sur le principal global et que vous essayez d’utiliser le réplica secondaire défini pour modifier le SEEDING_MODE DAG, un message d’erreur semblable au suivant peut s’afficher :
Remarque
- Msg 41168, Niveau 16, État 2, Numéro de ligne
- Une erreur s’est produite lors de la tentative d’accès au réplica de disponibilité avec l’ID *'ID Number'* dans le groupe de disponibilité « Group Name ». Le réplica de disponibilité est introuvable dans la configuration du groupe de disponibilité. Vérifiez que le nom du groupe de disponibilité et l’ID de réplica de disponibilité sont corrects, puis réessayez la commande.
Résolution
Ce problème est résolu dans les mises à jour cumulatives suivantes pour SQL Server :
Mise à jour cumulative 18 pour SQL Server 2017
Mise à jour cumulative 11 pour SQL Server 2016 SP2
Mise à jour cumulative 12 pour SQL Server 2016 SP1
À propos des mises à jour cumulatives pour SQL Server
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :
Dernière mise à jour cumulative pour SQL Server 2017
Dernière mise à jour cumulative pour SQL Server 2016
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Références
En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.