KB4589360 - CORRECTIF : erreur survenant lorsque vous activez la sauvegarde gérée ou automatisée dans SQL Server 2016 et 2017 si l’option « Autoriser l’accès public au Blob » est désactivée sur un compte de stockage

S’applique à
SQL Server 2017 on Windows SQL Server 2016 Service Pack 2

Symptômes

Supposons que vous désactivez l’option « Autoriser l’accès public au Blob » sur un compte de stockage. Dans ce cas, lorsque vous activez une sauvegarde gérée ou automatisée dans Microsoft SQL Server 2016 ou 2017, le message d’erreur suivant s’affiche :

Remarque

« SQL Server sauvegarde gérée vers Microsoft Azure ne peut pas configurer la base de données « DatabaseName » car une URL de conteneur n’a pas été fournie ou n’est pas valide. Il est également possible que vos informations d’identification SAS ne soient pas valides. »

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Résolution

Ce problème est résolu dans la mise à jour cumulative suivante pour SQL Server :

À propos des mises à jour cumulatives pour SQL Server :

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

Références

Découvrez la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.