KB4476977 - CORRECTIF : l’erreur 5901 se produit sur le même décalage en SQL Server 2016 jusqu’à ce que le serveur soit redémarré

S’applique à
SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use)

Symptômes

Supposons qu’une instance de Microsoft SQL Server 2016 soit installée et que les fichiers de base de données se trouvent sur un disque local. Lorsque les demandes d’E/S prennent plus de 15 secondes, SQL Server peut signaler les trois erreurs suivantes jusqu’à ce que le serveur soit redémarré :

Remarque

  • Spid DateTime SQL Server a rencontré 1 occurrence de demandes d’E/S prenant plus de 15 secondes sur le fichier [Chemin d’accès au fichier] dans l’ID de base de données : ID de base de données.
  • Délai d’expiration du verrou
  • Spid DateTime Un délai d’attente s’est produit pendant l’attente du verrouillage de mémoire tampon -- type 2, bp 00000051644A06C0, page 16:24731256, stat 0x40d, ID de base de données : ID de base de données

Erreur de point de contrôle :

  • Erreur SPID DateTime : 5901, Gravité : 16, État : 1.
    Espion DateTime Une ou plusieurs unités de récupération appartenant à la base de données « Nom de la base de données » n’ont pas pu générer de point de contrôle. Ce problème est généralement dû à un manque de ressources système telles que le disque ou la mémoire ou, dans certains cas, à une altération de la base de données. Pour plus d’informations sur cet échec, examinez les entrées précédentes du journal des erreurs.

Résolution

Ce problème est résolu dans la mise à jour cumulative suivante pour SQL Server :

Mise à jour cumulative 12 pour SQL Server 2016 SP1

À propos des mises à jour cumulatives pour SQL Server :

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

Dernière mise à jour cumulative pour SQL Server 2016

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Références

En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.