Symptômes
Une instruction DDL (Data Definition Language) de longue durée peut bloquer la tâche de déplacement de tuple en arrière-plan et provoquer un blocage. Très probablement, la tâche Tuple Mover sera choisie comme victime de l’impasse. Dans ce cas, Microsoft SQL Server peut se bloquer. En outre, des messages d’erreur semblables aux suivants s’affichent dans le journal des erreurs de SQL Server :
Remarque
Erreur : 1205, Gravité : 13, État : 18.
La transaction (ID <de processus, ID> de processus) a été bloquée sur les ressources de verrouillage avec un autre processus et a été choisie comme victime d’interblocage. Réexécutez la transaction.
ex_terminator : Arrêt possible en raison d’une exception lors du déroulement de la pile.
De même, lorsque la tâche de déplacement de tuple est exécutée sous un niveau de sollicitation élevé de la mémoire (par exemple, l’utilisation de la mémoire devient 100 %), la tâche de déplacement de tuple se termine de manière inattendue, ce qui provoque l’arrêt de SQL Server.
Résolution
Informations sur les mises à jour cumulatives
Le correctif de ce problème est inclus dans la mise à jour cumulative suivante pour SQL Server :
À propos des mises à jour cumulatives pour SQL Server
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :
Dernière mise à jour cumulative pour SQL Server 2016
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Références
En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.