Symptômes
Vous définissez l’essaimage automatique du groupe de disponibilité AlwaysOn dans une instance de Microsoft SQL Server 2016 ou 2017. Après avoir ajouté la base de données au groupe de disponibilité, un message d’erreur semblable au suivant s’affiche dans l’instance qui contient le réplica secondaire :
Remarque
Erreur 41169 : une erreur s’est produite lors de la tentative d’accès à la base de données du groupe de disponibilité avec l’ID « %.*ls » dans le groupe de disponibilité « %.*ls ». La base de données de disponibilité est introuvable dans la configuration du groupe de disponibilité. Vérifiez que le nom du groupe de disponibilité et l’ID de la base de données de disponibilité sont corrects, puis relancez la commande.
Cause
Ce problème se produit parce que l’amorçage automatique peut échouer de manière aléatoire à initialiser la base de données de disponibilité.
Résolution
Ce correctif est inclus dans les mises à jour cumulatives suivantes pour SQL Server :
Mise à jour cumulative 1 pour SQL Server 2017
Mise à jour cumulative 5 pour SQL Server 2016 Service Pack 1
À propos des builds de SQL Server
Chaque nouvelle build de SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la build précédente. Nous vous recommandons d’installer les dernières mises à jour cumulatives pour SQL Server :
Dernière mise à jour cumulative pour SQL Server 2017
Dernière build pour SQL Server 2016
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Références
En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.