Symptômes
Prenons le scénario suivant :
- Vous créez un serveur lié dans Microsoft SQL Server 2016 ou 2017 qui pointe vers une instance distante de SQL Server 2012 ou dʼune version ultérieure.
- Vous souhaitez utiliser la fonction LOG() sans spécifier explicitement la base du logarithme (pour calculer un algorithme naturel).
Lorsque vous exécutez une requête qui appelle LOG() avec un argument référençant une table distante, une erreur de violation d’accès peut se produire dans certaines conditions (par exemple : si votre requête utilise UNION et une fonction d’agrégation telle que SOMME()).
En outre, un fichier d’image mémoire est généré sur l’instance locale.
Msg 596, Niveau 21, État 1, Ligne LineNumber
Impossible de continuer l’exécution car la session est à l’état d’arrêt.
Msg 0, Niveau 20, État 0, Ligne LineNumber
Une grave erreur s’est produite sur la commande actuelle. Les résultats, s’il y en a, doivent être ignorés.
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Résolution
Ce problème est résolu dans les mises à jour cumulatives suivantes pour SQL Server :
À propos des mises à jour cumulatives pour SQL Server :
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :
- Dernière mise à jour cumulative pour SQL Server 2017
- Dernière mise à jour cumulative pour SQL Server 2016
Références
En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.