KB4014734 - CORRECTIF : SQL Server service Launchpad ne démarre pas si la version installée de R Services (en base de données) est différente du moteur de base de données dans SQL Server 2016

S’applique à
SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use) SQL Server 2016 Service Pack 1

Symptômes

Si vous installez R Services (In-Database) séparément du moteur de base de données dans Microsoft SQL Server 2016 et si leurs versions sont différentes, le service Launchpad de SQL Server peut ne pas démarrer. En outre, les messages d’erreur semblables aux suivants sont consignés dans le journal des erreurs de SQL Server :

Remarque

  • Un délai d’attente a été atteint (30 000 millisecondes) en attendant la connexion du service SQL Server Launchpad (BI_DW).
  • Le service SQL Server Launchpad (BI_DW) n’a pas pu démarrer en raison de l’erreur suivante : le service n’a pas répondu à la demande de démarrage ou de contrôle en temps voulu.

Résolution

Ce problème est résolu dans les mises à jour cumulatives suivantes pour SQL Server :

Mise à jour cumulative 5 pour SQL Server 2016 RTM

Mise à jour cumulative 2 pour SQL Server 2016 SP1

À propos des mises à jour cumulatives pour SQL Server

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

Dernière mise à jour cumulative pour SQL Server 2016

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Références

En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.