Symptômes
Prenons le scénario suivant :
- Vous disposez d’une base de données de groupe de disponibilité (AG) AlwaysOn dans Microsoft SQL Server 2016.
- Vous redémarrez le service Microsoft Distributed Transaction Coordinators (DTC).
- Supposons que vous exécutez une transaction distribuée dans la base de données activée pour AG. Dans ce cas, vous pouvez constater que la transaction échoue avec des erreurs semblables à la suivante :
Remarque
Msg 8510, Niveau 20, État 3, Ligne LineNumber
Échec de l’opération d’inscription : 0x8004d01c(XACT_E_CONNECTION_DOWN). SQL Server n’a pas pu s’enregistrer auprès de Microsoft Distributed Transaction Coordinator (MS DTC) en tant que gestionnaire de ressources pour cette transaction. La transaction a peut-être été arrêtée par le client ou le responsable de ressources.
Msg 596, Niveau 21, État 1, Ligne LineNumber
Impossible de continuer l’exécution car la session est à l’état d’arrêt.
Msg 0, Niveau 20, État 0, Ligne LineNumber
Une grave erreur s’est produite sur la commande actuelle. Les résultats, s’il y en a, doivent être ignorés.
Solution de contournement
Une solution de contournement à ce problème est que lorsque vous redémarrez le service SQL Server, l’erreur peut ne pas s’afficher.
Résolution
Ce problème est résolu dans la mise à jour cumulative suivante pour SQL Server :
Mise à jour cumulative 6 pour SQL Server 2016 SP1
À propos des mises à jour cumulatives pour SQL Server :
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :
Dernières mises à jour cumulatives pour SQL Server 2016
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Références
En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.