KB3210087 - CORRECTIF : erreurs lors de la tentative d’enregistrement de règles métier MDS dans SQL Server 2016

S’applique à
SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use)

Symptômes

L’une des mises à jour suivantes pour SQL Server 2016 est installée :

  • 3194716 MS16-136 : Description de la mise à jour de sécurité pour SQL Server 2016 GDR datée du 8 novembre 2016
  • 3194717 MS16-136 : Description de la mise à jour de sécurité pour SQL Server mise à jour cumulative 2016 datée du 8 novembre 2016
  • Informations sur 3182545 SQL Server 2016 Service Pack 1

Lorsque vous essayez d’enregistrer une règle métier qui a un argument postfix dans Master Data Services (MDS), vous recevez un message d’erreur semblable au suivant :

Remarque

La séquence doit être supérieure à zéro.

En outre, lorsque vous essayez d’enregistrer une règle métier qui utilise un script défini par l’utilisateur comme condition ou action, un message d’erreur semblable au suivant s’affiche :

Remarque

La règle métier contient des éléments de règle endommagés, car le script SQL correspondant a été modifié.

      

Résolution

Le correctif de ce problème est inclus dans les mises à jour suivantes :

      

À propos des builds de SQL Server 2016

À propos des builds de SQL Server 2016

Chaque nouvelle version de SQL Server 2016 contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente. Nous vous recommandons d’installer la dernière version de SQL Server 2016.

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Références

En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.