KB4013112 - CORRECTION : ERREUR « AJOUTER UN POINT POUR SYSTEM_TIME a échoué » lorsque vous ajoutez des colonnes de point à une table à mémoire optimisée dans SQL Server 2016

S’applique à
SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use)

Symptômes

Supposons que vous utilisez In-Memory OLTP dans Microsoft SQL Server 2016. Dans ce scénario, vous utilisez les instructions ALTER TABLE et ADD POINT FOR SYSTEM_TIME pour ajouter à une table optimisée la mémoire des colonnes de période qui ont les valeurs par défaut appropriées ainsi que la période de temps système correspondante. Si le tableau n’est pas vide, un message d’erreur semblable au suivant s’affiche :

Remarque

Msg 13575, Niveau 16, État 0
L’AJOUT D’UN POINT POUR SYSTEM_TIME a échoué car la table « TableName » contient des enregistrements pour lesquels la fin de la période n’est pas égale à la date et heure MAX.

Résolution

Ce correctif est inclus dans les mises à jour suivantes :

À propos des builds de SQL Server 2016

Chaque nouvelle version de SQL Server 2016 contient tous les correctifs logiciels et correctifs de sécurité inclus dans la version précédente. Nous vous recommandons d’installer la dernière version de SQL Server 2016.

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Références

Découvrez la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.