KB4051356 - CORRECTIF : échec de la restauration de la base de données mémoire avec des erreurs dans SQL Server 2016 et SQL Server 2017

S’applique à
SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use) SQL Server 2016 Service Pack 1 SQL Server 2017 Enterprise SQL Server 2017 Enterprise Core SQL Server 2017 Developer

Symptômes

Prenons le scénario suivant :

  • Vous disposez d’une base de données qui utilise le traitement des transactions en ligne (OLTP) en mémoire dans Microsoft SQL Server 2016 ou SQL Server 2017.
  • Un lecteur de disque contient $FSLOG affiché comme étant PLEIN.

Dans ce scénario, la restauration de la base de données échoue dans l’une des conditions suivantes :

  • Lorsque vous redémarrez le service SQL Server. Dans ce cas, si la base de données redémarre, vous remarquerez peut-être que la récupération de la base de données échoue et renvoie une erreur 5511. En outre, la base de données peut passer en mode SUSPECT.
  • Lorsque vous essayez de restaurer une base de données à partir d’une sauvegarde. Dans ce cas, la base de données peut ne pas être mise en ligne en raison de l’altération de l’enregistrement du journal du système de fichiers. Par exemple, si le nom de fichier contient le modèle de nom « ffff ».

Dans ces conditions, des messages d’erreur semblables au suivant peuvent s’afficher :

Remarque

Msg 5511, Niveau 16, État 10
L’enregistrement du journal du système de fichiers de FILESTREAM « fba1eafd-fc759c68-ffff.045e1502-038a6397-0000.d790ce11-7d80-4654-9ec0-0c7f4f7c5388.0-0.1000016 » sous le dossier du journal est endommagé.

Msg 3167, Niveau 16, État 1
RESTORE n’a pas pu démarrer la base de données DatabaseName

Msg 3013, Niveau 16, État 1
La base de données de restauration se termine anormalement.

Msg 3414, Niveau 21, État 1
Une erreur s’est produite lors de la récupération, empêchant le redémarrage de la base de données DatabaseName . Diagnostiquez les erreurs de récupération et corrigez-les, ou restaurez à partir d’une sauvegarde réputée correcte. Si des erreurs ne sont pas corrigées ou prévues, contactez le support technique

Résolution

Ce problème est résolu dans la mise à jour cumulative suivante pour SQL Server :

Mise à jour cumulative 3 pour SQL Server 2017

Mise à jour cumulative 6 pour SQL Server 2016 SP1

À propos des mises à jour cumulatives pour SQL Server :

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

Dernière mise à jour cumulative pour SQL Server 2017

Dernière mise à jour cumulative pour SQL Server 2016

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Références

En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.