KB4052984 - CORRECTIF : erreur lors de la sauvegarde d’une base de données avec des tables à mémoire optimisée dans SQL Server 2017

S’applique à
SQL Server 2017 Developer on Windows SQL Server 2017 Enterprise on Windows SQL Server 2017 Enterprise Core on Windows SQL Server 2017 Standard on Windows

Symptômes

Supposons que vous utilisez In-Memory traitement des transactions en ligne (OLTP) dans SQL Server 2017 sur Windows. Lorsque vous essayez de sauvegarder une base de données qui contient des tables OLTP à mémoire optimisée et un ou plusieurs conteneurs dans le groupe de fichiers à mémoire optimisée stocké dans Stockage Blob Microsoft Azure, vous pouvez remarquer que l’opération de sauvegarde peut échouer avec un message d’erreur semblable au suivant :

Remarque

  • Erreur : 3633, Gravité : 16, État : 1.
  • Le système d’exploitation a renvoyé l’erreur « 2(le système ne trouve pas le fichier spécifié) » lors de la tentative de 'BackupDataFile ::Open' sur 'FilePath\FileName.hkckp' à 'fileprod.cpp'(988).

En outre, une violation d’accès peut se produire occasionnellement.

Résolution

Ce problème est résolu dans la mise à jour cumulative suivante pour SQL Server :

Mise à jour cumulative 2 pour SQL Server 2017

À propos des mises à jour cumulatives pour SQL Server :

Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :

Dernière mise à jour cumulative pour SQL Server 2017

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Références

En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.