Symptômes
Lorsque vous utilisez des groupes de disponibilité Always On dans Microsoft SQL Server sur Linux, une base de données qui appartient à un groupe de disponibilité peut être marquée comme SUSPECTE. En outre, les messages d’erreur semblables aux suivants sont consignés dans le journal des erreurs de SQL Server :
Remarque
- Erreur : 883, Gravité : 16, État : 1.
- Impossible de créer la table Write Page Recorder : wpr_bucket_table pour la base de données WritePageRecorder2 ::CreateWPRBucketTable.
- Erreur : 926, Gravité : 14, État : 1.
- Impossible d’ouvrir les database_name de base de données. Il a été marqué SUSPECT par récupération. Pour plus d’informations, consultez le journal des erreurs de SQL Server.
Résolution
Ce problème est résolu dans la mise à jour suivante pour SQL Server :
Mise à jour cumulative 8 pour SQL Server 2017
À propos des builds de SQL Server
Chaque nouvelle build de SQL Server contient tous les correctifs logiciels et correctifs de sécurité qui se trouvaient dans la version précédente. Nous vous recommandons d’installer la version la plus récente pour votre version de SQL Server :
La dernière build pour SQL Server 2017
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Références
Découvrez la terminologie standard utilisée par Microsoft pour décrire les mises à jour logicielles.