Symptômes
Après avoir appliqué la mise à jour cumulative 21 (CU21) de SQL Server 2017 sur Windows Server 2012 ou Windows 8, les fonctionnalités Filestream et FileTable peuvent ne pas fonctionner correctement.
Vous pouvez voir le message suivant dans le journal des erreurs du serveur :
FILESTREAM : échec de la connexion au pilote du noyau RsFx0504.
<{1038F43D-3391-45F7-B1B3-BADF26459429}>Échec de l’initialisation de CFsaShareFilter : 0x80070002 d’erreur (-2147024894)
Le message suivant peut apparaître dans le journal des événements système Windows :
Le service de pilote RsFx0504 n’a pas pu démarrer en raison de l’erreur suivante : Windows ne peut pas vérifier la signature numérique de ce fichier. Il est possible qu'une modification matérielle ou logicielle récente ait installé un fichier endommagé ou dont la signature est incorrecte, ou qu'il s'agisse d'un logiciel malveillant provenant d'une source inconnue.
En outre, vous pouvez rencontrer des échecs lorsque vous essayez d’installer la mise à jour cumulative ou d’activer la fonctionnalité Filestream une fois la mise à jour cumulative installée.
État
Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».
Résolution
Ce problème est résolu dans la mise à jour cumulative suivante pour SQL Server :
À propos des mises à jour cumulatives pour SQL Server :
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :
Solution de contournement
Pour contourner ce problème, vous pouvez désinstaller CU21.
Références
En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.