KB4230542 - CORRECTIF : échec de la promotion Pacemaker de l’réplica locale en primaire lors de l’utilisation d’AlwaysOn AG dans SQL Server 2017

S’applique à
SQL Server 2017 Enterprise SQL Server 2017 Enterprise Core SQL Server 2017 Developer

Symptômes

Supposons que vous utilisez des groupes de disponibilité (AG) AlwaysOn dans SQL Server 2017 sur un cluster Pacemaker. Vous remarquerez peut-être que Pacemaker ne parvient pas à promouvoir un réplica AG au rôle de master et le message d’erreur suivant s’affiche :

Remarque

INFO : promouvoir : ERREUR : DateTime Impossible de promouvoir le réplica local en RÔLE PRINCIPAL : RoleName : cette opération ne peut pas être effectuée sur le groupe de disponibilité « GroupName » car il est de type cluster EXTERNE. Utilisez les outils de gestion de cluster pour effectuer l’opération.

Résolution

Un correctif pour ce problème est inclus dans la mise à jour cumulative 7 pour SQL Server 2017.

À propos des builds de SQL Server 2017

Chaque nouvelle version de SQL Server 2017 contient tous les correctifs logiciels et correctifs de sécurité qui se trouvaient dans la version précédente. Nous vous recommandons d’installer la dernière version pour SQL Server 2017.

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».

Références

Découvrez la terminologie standard utilisée par Microsoft pour décrire les mises à jour logicielles.