Amélioration
Lorsque le nouvel indicateur de trace (TF) 8089 est spécifié comme l’un des paramètres de démarrage, SQL Server commence à effectuer le suivi des allocations de mémoire pour une génération d’image mémoire filtrée plus rapide. La faible quantité de surcharge peut être observée avec cet indicateur de trace.
Dès que la TF 8089 est activée, vous remarquerez un message d’erreur semblable au suivant dans le journal des erreurs :
DateTime Server Le bitmap d’exclusion de page est activé.
Résolution
Cette mise à jour est incluse dans la mise à jour cumulative suivante pour SQL Server :
Important
À partir de la mise à jour cumulative 20 (CU20) de SQL Server 2017, la fonctionnalité de filtrage bitmap est activée par défaut. L’indicateur de trace T8089 ne sera plus appliqué et sera ignoré même s’il est activé. La fonctionnalité de filtrage bitmap peut être désactivée via l’indicateur de trace T8095.
À propos des mises à jour cumulatives pour SQL Server :
Chaque nouvelle mise à jour cumulative pour SQL Server contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la mise à jour cumulative précédente. Consultez les dernières mises à jour cumulatives pour SQL Server :
Références
En savoir plus à propos de la terminologie utilisée par Microsoft pour décrire les mises à jour logicielles.